Currently website builder is experiencing some issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 07:56 UTC

Update

Fixes are made. Currently depolying them to live.
Posted Jan 08, 2026 - 07:55 UTC

Investigating

Currently website builder is experiencing some issues. Fixes are incoming.
Posted Jan 08, 2026 - 07:51 UTC
This incident affected: Hostinger Website Builder (Editor).