Hostinger Website Builder Emergency Maintenance

Incident Report for Hostinger

Resolved

Problem is mitigated. All systems are operational.
Posted Jun 05, 2026 - 10:13 UTC

Update

We noticed some abnormalities on publishing feature. This should now be resolved, we continuing on monitoring.
Posted Jun 05, 2026 - 08:45 UTC

Monitoring

We’ve identified the issue which affects some users of the Website Builder. A fix has been applied and our team is monitoring the situation.
Posted Jun 05, 2026 - 06:03 UTC

Investigating

We’re investigating an issue affecting some users of the Website Builder. Impacted users may experience limited functionality across editor and store admin panel. Our team is actively working to identify the cause and restore normal service as quickly as possible. We apologize for the inconvenience.
Posted Jun 04, 2026 - 23:59 UTC