Hostinger Website Builder – SSL/Custom Domain Access Issues

Incident Report for Hostinger

Resolved

We think the impact from the issue is over.
Posted Jun 23, 2026 - 10:02 UTC

Monitoring

We think the impact from the issue is over.
Posted Jun 23, 2026 - 08:42 UTC
This incident affected: Hostinger Website Builder (User sites).