Hostinger Websites Issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 07:28 UTC

Investigating

We have noticed some connection timeouts in our main Websites infrastructure, for that reason you may experience issues while trying to update website or plugin with error message:

Installation failed: Download failed CURL error 60: SSL certificate problem: certificate has expired

Our team is currently working on resolution and please note that client websites are not affected. Thank You for Your patience.
Posted Feb 12, 2026 - 05:26 UTC
This incident affected: Core Services (Hostinger Websites).