HPANEL: Free Mail service maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 13:45 UTC
Investigating
We are performing Free Mail service maintenance in hPanel section. Some clients may experience service interruptions while using Hostinger Free Mail services.
Apologies for any inconvenience. Thank you for your patience.
Posted Sep 16, 2020 - 13:23 UTC
This incident affected: Email Hosting services (Hostinger Mail).