Website issue when both CDN and Cloudflare are enabled.

Incident Report for Hostinger

Resolved

Resolved.
Posted Sep 20, 2025 - 03:57 UTC

Monitoring

The issue seems better now.
Posted Sep 19, 2025 - 08:24 UTC

Identified

The issue has been identified.
Posted Sep 19, 2025 - 07:26 UTC

Investigating

We are currently investigating an issue where websites using both hCDN and Cloudflare are experiencing "Error 522."
Posted Sep 19, 2025 - 05:42 UTC