This incident has been resolved. We apologize for any inconvenience caused
Posted Dec 11, 2025 - 05:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 05:17 UTC
Update
We are still actively trying to mitigate the issues along to bring back our services back to normal operations.
Posted Dec 11, 2025 - 05:09 UTC
Update
We are still actively trying to mitigate the issues along with our service providers to bring back our services back to normal operations.
Posted Dec 11, 2025 - 04:43 UTC
Identified
We’ve identified that the issue is being caused by an unexpected large increase in DNS traffic to our infrastructure.
Posted Dec 11, 2025 - 04:30 UTC
Update
We are still investigating what cause the degraded performance on our service, increasing the scope to add slow response on our hpanel service.
Sorry for the inconvenience
Posted Dec 11, 2025 - 04:10 UTC
Update
Update we see the increase in impact not just affecting mail but also affecting our DNS service, we are still investigating the issue, sorry for the inconvenience
Posted Dec 11, 2025 - 03:47 UTC
Investigating
We’re investigating an issue causing delays in email delivery. Some users may also be unable to view emails after logging in. All messages are safely queued and will be delivered once the issue is resolved. We apologize for the inconvenience and appreciate your patience.
Posted Dec 11, 2025 - 03:31 UTC
This incident affected: Hostinger Email (Hostinger Mail) and Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend, Hostinger DNS).