SMTP related Free Mail issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 16:28 UTC
Identified
We have detected increased delays in SMTP sending / receiving and some general errors regarding SMTP connection. We apologize for any inconveniences this may cause and please note, that all emails will be delivered, just with a delay. Thank You.
Posted Sep 01, 2020 - 12:50 UTC