Webmail Connection Issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Feb 22, 2021 - 17:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2021 - 17:27 UTC

Update

We are continuing to investigate this issue.
Posted Feb 22, 2021 - 17:06 UTC

Investigating

Some clients are reporting issues logging in to Webmail. We are investigating the issue. We will provide further updates as necessary. Thank You for Your patience.
Posted Feb 22, 2021 - 16:29 UTC
This incident affected: Hostinger Email (Hostinger Webmail).