Free mail service maintenance (webmail)
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 15:46 UTC
Investigating
Some users might be experiencing issues while logging into their mailboxes / Webmail. We have detected the issue and are already working on a long-term solution. Thank You for Your patience.
Posted Apr 28, 2020 - 14:54 UTC
This incident affected: Core Services (Email service).