Free mail service maintenance (webmail)
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 12:36 UTC
Investigating
We are performing Free Mail service maintenance for Webmail client. Clients will experience from 10 to 60 minutes long service interruptions while using Hostinger Webmail client.
Apologies for any inconveniences. Thank you for your patience.
Posted Feb 18, 2020 - 12:14 UTC
This incident affected: Core Services (Email service).