Emergency Server us-1622 Maintenance

Incident Report for Hostinger

Update

The server is stable and fix
Posted Jul 25, 2026 - 19:35 UTC

Monitoring

The server is working with normal levels of performance, we will continue to monitor.
Posted Jul 25, 2026 - 17:42 UTC

Identified

We pushed a fix and are monitoring the results
Posted Jul 25, 2026 - 17:37 UTC

Investigating

We are performing an emergency maintenance on server 1622, located in the us. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Jul 25, 2026 - 17:16 UTC