Maintenance on hostinger.co website
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Jul 30, 2019 - 15:15 UTC
Investigating
We are currently performing maintenance on hostinger.co website. Hosting services are not affected.
We will keep updating.
Posted Jul 30, 2019 - 14:44 UTC
This incident affected: Core Services (Hostinger Website).