Emergency Network Maintenance in Indonesia Datacenter

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 14:31 UTC

Monitoring

A fix was applied and we are monitoring the results.
Posted Jun 19, 2026 - 14:14 UTC

Update

The root cause has been identified and we're actively working with our partners to remedy the issue. Thanks for your patience.
Posted Jun 19, 2026 - 12:36 UTC

Identified

We are performing an emergency Network maintenance in the Indonesia datacenter. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Jun 19, 2026 - 10:53 UTC