The server is stable and load is back to regular levels.
Posted Mar 27, 2026 - 18:13 UTC
Monitoring
A fix has ben pushed and the server is operational. We are monitoring the results for any further issues.
Posted Mar 27, 2026 - 17:54 UTC
Update
We continue to work on the server. Thanks for your patience.
Posted Mar 27, 2026 - 17:27 UTC
Update
We are performing server emergency maintenance. The fix is under way, thanks for your patience.
Posted Mar 27, 2026 - 16:00 UTC
Identified
We are performing an emergency maintenance on server 1393, located in Singapore. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.