The server u4s-node41 located in France is experiencing degraded performance, we are currently working on a fix and monitoring closely. Thank you for your patience.
Posted May 04, 2026 - 14:36 UTC
Update
We are continuing to investigate the issue. Clients might experience intermittent website accessibility issues.
Posted May 04, 2026 - 13:21 UTC
Investigating
We are performing an emergency maintenance on server u4s-node41, located in France. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.