Incoming Mail Delivery Issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 10:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2025 - 07:37 UTC
Update
We are continuing to investigate this issue.
Posted Feb 04, 2025 - 07:11 UTC
Investigating
We are currently investigating an issue where some emails may land in your junk folder. Our team is actively working to resolve this, and we want to assure you that no emails are lost during delivery.
We appreciate your patience and will restore full mail functionality as soon as possible. Thank you for your understanding.
Posted Feb 04, 2025 - 06:50 UTC
This incident affected: Email Hosting services (MailChannels service, Hostinger Mail SMTP Outbound, Hostinger Mail SMTP Inbound) and MailChannels SMTP Service.