Website Builder Ecommerce Outage
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Oct
24
,
2025
-
19:35
UTC
Monitoring
Ecommerce is working again, monitoring the situation.
Posted
Oct
24
,
2025
-
19:27
UTC
Update
Ecommerce is down, still investigating
Posted
Oct
24
,
2025
-
18:53
UTC
Investigating
We are currently investigating the issue with Website Builder Ecommerce. Users may face some errors and degraded performance.
Posted
Oct
24
,
2025
-
18:16
UTC
This incident affected: Hostinger Website Builder (User sites, Ecommerce).
×
Subscribe to Incident
Subscribe to updates for
Website Builder Ecommerce Outage
via . You'll receive .