Mail service maintenance (Webmail)
Incident Report for Hostinger International
Resolved
The maintenance has been finished.
Posted Dec 04, 2019 - 15:07 UTC
Identified
We are performing Free Mail service maintenance for Webmail client. Clients will experience from 10 to 60 minutes long service interruptions while using Hostinger Webmail client.
Apologies for any inconveniences. Thank you for your patience.
Posted Dec 04, 2019 - 12:46 UTC