Domain registration and management issues
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Oct
31
,
2024
-
18:28
UTC
Investigating
We are currently experiencing temporary infrastructure issues that might directly impact our users who are trying to register or manage domains. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted
Oct
31
,
2024
-
18:06
UTC
×
Subscribe to Incident
Subscribe to updates for
Domain registration and management issues
via . You'll receive .