Domain registration issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Sep 24, 2023 - 04:05 UTC

Investigating

One of our domain providers is currently experiencing temporary infrastructure maintenance that might directly impact our users who are trying to register a new domain. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Sep 24, 2023 - 02:29 UTC