A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 12:46 UTC
Investigating
Hostinger Support Platform is currently experiencing technical issues that may affect various platform features. Our engineering team has identified the issue and is working on implementing a solution. We expect to restore full service shortly. Thank you for your understanding.
Posted Nov 06, 2025 - 12:37 UTC
This incident affected: Core Services (Support Portal).