Hostinger Website Builder: 30-day long digital products, gift cards and invoice emails not being sent

Incident Report for Hostinger

Resolved

Incident has been resolved.
Posted Jul 21, 2025 - 14:17 UTC

Investigating

We’ve identified an issue where emails for digital products with 30-days expiration date, gift cards, and invoice emails are not being sent.
Posted Jul 15, 2025 - 15:18 UTC
This incident affected: Hostinger Website Builder (Ecommerce).