Core Infrastructure Connectivity Issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 00:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 00:05 UTC

Identified

We’ve identified a possible issue caused by an unexpected surge in DNS traffic from one of our service providers. We’re working with our engineers to measure the impact.
Posted Dec 02, 2025 - 23:58 UTC

Investigating

One of our third party providers is currently experiencing network issues that might directly impact our users. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Dec 02, 2025 - 23:37 UTC
This incident affected: Hostinger Email (Hostinger Mail) and Core Services (Hostinger Websites, Hostinger DNS).