Website Builder / Horizons Order Payments Partial Outage

Incident Report for Hostinger

Monitoring

We have identified and fixed the partial payment outage for orders, now we're monitoring to make sure no more such cases repeats.
Posted May 27, 2026 - 18:18 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 27, 2026 - 17:27 UTC
This incident affects: Hostinger Website Builder (Ecommerce).