Hostinger.com login maintenance
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Sep 24, 2019 - 00:40 UTC
Identified
We are performing maintenance on hostinger.com login page so some clients may experience intermittent issues to log in. Sorry for the inconveniences.
Posted Sep 23, 2019 - 13:01 UTC
This incident affected: Core Services (Hostinger Website).