.CA domains registration/management issues
Incident Report for
Hostinger
Resolved
Issue has been solved
Posted
May
14
,
2026
-
06:14
UTC
Investigating
We are having issues with .ca domains registrations and management. We are currently working on resolving it. Thank you for your patience
Posted
May
14
,
2026
-
05:32
UTC
This incident affected: Core Services (Domain Registration & Management System).
×
Subscribe to Incident
Subscribe to updates for
.CA domains registration/management issues
via . You'll receive .