A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 06:21 UTC
Investigating
Some users might be experiencing an issue with website publishing. Our team is aware and actively working on a fix. We’ll post updates here as we have them.
Posted Feb 26, 2026 - 15:06 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor).