A fix has been implemented and we are monitoring the results.
Posted Oct 25, 2024 - 14:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 25, 2024 - 14:02 UTC
Investigating
We are currently experiencing temporary email system infrastructure issues that might directly impact some of our users who are trying to login into Webmail. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Oct 25, 2024 - 13:58 UTC
This incident affected: Email Hosting services (Hostinger Webmail).