Up to 1% of domains might experience management issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 06:52 UTC

Investigating

We are currently investigating an issue affecting a small subset of domains — approximately 1% — which may be experiencing temporary management disruptions.
Posted Jul 01, 2025 - 06:36 UTC