Hostinger websites maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 12, 2020 - 11:42 UTC
Investigating
We are currently performing maintenance on main Hostinger websites. Visitors might experience interruptions loading our main websites.
Posted May 12, 2020 - 09:44 UTC
This incident affected: Core Services (Hostinger Website).