Hostinger Websites Issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 18:52 UTC

Investigating

We have noticed some connection timeouts in our suport Websites infrastructure, for that reason You may experience issues while trying to reach suport Hostinger pages. Our team is currently working on resolution and please note that client websites are not affected. Thank You for Your patience.
Posted Aug 14, 2025 - 17:14 UTC
This incident affected: Core Services (Hostinger Websites).