A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2025 - 20:36 UTC
Investigating
One of our providers is currently experiencing network issues that might directly impacting users. We are currently working on a resolution and will update You in the process. Thank You for Your patience.
Posted Dec 06, 2025 - 20:33 UTC
This incident affected: Hostinger Email (Hostinger Mail) and Core Services (Hostinger Websites, Hostinger DNS).