Hostinger maintenance

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jul 17, 2020 - 22:09 UTC

Investigating

There is currently an issue with hPanel not being loaded properly. The issue is known and should be resolved shortly. Thank You for Your patience.
Posted Jul 17, 2020 - 21:39 UTC
This incident affected: Core Services (Client Portal).