A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 10:18 UTC
Update
We are still actively trying to mitigate the issues along with our service providers to bring back our services back to normal operations.
Posted Nov 20, 2025 - 10:13 UTC
Identified
We’ve identified that the issue is being caused by an unexpected large increase in DNS traffic coming through one of our service providers. We’re coordinating with them to fix the problem and bring services back to normal operations.
Posted Nov 20, 2025 - 09:26 UTC
Investigating
Widespread service degradation impacting hPanel, Builder, Horizons, email services, and hCDN. Root cause under investigation. Mitigation measures in progress.