Global Paysera outage

Incident Report for Hostinger

Resolved

The incident has been resolved by Paysera.
Posted Feb 12, 2025 - 07:23 UTC

Update

Customers attempting to purchase Hostinger services using Paysera may be affected by the ongoing outage. We recommend using alternative payment methods at this time.
Posted Feb 11, 2025 - 12:28 UTC

Investigating

Paysera is currently experiencing a global outage. As a result, we have temporarily disabled Paysera as a payment option for Website Builder ecommerce customers. We will restore the service as soon as the provider resolves the issue. Thank you for your patience.
Posted Feb 11, 2025 - 11:46 UTC
This incident affected: Core Services (Billing System) and Hostinger Website Builder (Ecommerce).