A fix has been pushed and we are monitoring the results.
Posted Sep 08, 2026 - 16:53 UTC
Investigating
We are investigating a problem on a subset of hosting servers. On affected servers. Client websites hosted there could be temporarily inaccessible or may return 508 or 503, and File Manager may fail to open with 403 error. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Sep 08, 2026 - 12:16 UTC
This incident affected: Web Hosting services (Hostinger File Manager) and Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend).