A fix has been implemented, and we're monitoring the results.
Posted Jun 18, 2026 - 08:00 UTC
Identified
We have identified the cause of the issue and are deploying a fix.
Posted Jun 18, 2026 - 07:40 UTC
Investigating
We are investigating an issue affecting Agency Hosting actions, including website creation and onboarding. Existing websites remain available, but some platform actions, such as creating a new website, may fail or take longer than expected.
Our team is working on the issue, and we will share updates as soon as more information is available.
Posted Jun 18, 2026 - 07:19 UTC
This incident affected: Hostinger Agency Hosting (Hostinger Agencies).