Printful Integration Failures in Website Builder Stores

Incident Report for Hostinger

Resolved

Features disabled until checking up with Printful.
Users are informed via the UI
Posted Jun 13, 2026 - 20:52 UTC

Monitoring

Disabled Printful features as for now.
Working on adjustments in the meantime
Posted Jun 13, 2026 - 20:22 UTC

Identified

We are hitting rate limits on Printful OAuth API.
Investigating why that has happened and disabling current Printful features in the meantime as well.
Posted Jun 13, 2026 - 19:23 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 13, 2026 - 19:15 UTC

Investigating

We are currently investigating an issue affecting the Printful integration for Website Builder stores.

Some users may encounter an error when attempting to add or connect Printful to their online store, preventing the integration from being completed successfully.
We will provide additional updates as soon as more information becomes available.
Posted Jun 13, 2026 - 19:07 UTC
This incident affected: Hostinger Website Builder (Ecommerce).