Scheduled Server US-141 maintenance
Scheduled for May 19, 08:00 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 16, 2022 - 10:21 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 16, 2022 - 09:27 UTC
Scheduled
We are performing scheduled server maintenance. Clients will experience up to 60-minute long Service interruptions. We will provide further updates as necessary.
Posted May 12, 2022 - 15:57 UTC
This scheduled maintenance affects: Hostinger Shared Hosting (us-imm-web141.main-hosting.eu).