The issue is now resolved, Email services are operating normally. Thank you for your patience throughout the recovery process.
Posted Oct 08, 2025 - 01:26 UTC
Update
Email queue processing has completed, and all queued messages have been delivered. We are currently monitoring the system to ensure that email services remain stable. Our next update will be provided within 1 hour. Thank you for your patience throughout the recovery process.
Posted Oct 08, 2025 - 00:29 UTC
Update
Update: Our engineering team has restored core email functionality, and services remain operational. However, email queue processing is taking longer than expected due to high system load. Current Impact: Queued emails are still being processed and will be delivered into mailboxes as processing continues. All pending messages will be delivered eventually. Data Security: No emails or data were lost during this incident. All messages have been securely stored and are being delivered as the queue clears. Our next update will be provided once email queue processing has completed. We understand this prolonged disruption was frustrating and sincerely thank you for your patience throughout the recovery process.
Posted Oct 07, 2025 - 23:22 UTC
Update
Update: Our engineering team has restored core email functionality, and services remain operational. However, email queue processing is taking longer than expected due to high system load. Current Impact: Queued emails are still being processed and will be delivered into mailboxes as processing continues. All pending messages will be delivered eventually. Data Security: No emails or data were lost during this incident. All messages have been securely stored and are being delivered as the queue clears. Our next update will be provided once email queue processing has completed. We understand this prolonged disruption was frustrating and sincerely thank you for your patience throughout the recovery process.
Posted Oct 07, 2025 - 21:34 UTC
Monitoring
Update: Our engineering team has restored core email functionality, and services are now operational. However, due to high system load, performance remains reduced while recovery efforts continue to stabilize the platform. Current Impact: Queued emails are still being processed and will be delivered as system performance improves. Data Security: No emails or data were lost during this incident. All messages have been securely stored and are being delivered as the queue clears. Our next update will be provided once system performance has fully stabilized. We understand this prolonged disruption was frustrating and sincerely thank you for your patience throughout the recovery process.
Posted Oct 07, 2025 - 20:30 UTC
Update
Update: Our engineering team reports that email services are nearly fully recovered. Final restoration steps are in progress to ensure all systems return to normal operation. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 19:57 UTC
Update
Update: Our engineering team continues work on restoring email services to their fully operational state. The restoration process is still in progress, and systems are steadily recovering. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 19:34 UTC
Update
Update: Our engineering team has begun restoring email services to their fully operational state. Systems are recovering, and users should start to see gradual improvement as restoration continues. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 19:09 UTC
Update
Update: Our engineering team has successfully rebuilt the data storage cluster, and the system is now undergoing rebalancing. Once this process is complete, email services will be fully restored. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 18:38 UTC
Update
Update: Our engineering team continues work on recovering the data storage cluster. The situation remains unchanged as recovery efforts are still in progress to fully restore email services. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 17:59 UTC
Update
Update: Our engineering team continues work on recovering the data storage cluster. Progress is being made, but the recovery process is still ongoing as we work to fully restore email services to normal operation. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 17:32 UTC
Identified
Update: Our engineering team has identified the root cause of the email service issues. One of the data storage fragments has been successfully restored, and work is underway to safely bring the remaining parts of the cluster back online to fully restore email services. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 16:40 UTC
Update
Update: Our engineering team continues to investigate the email service issues. The situation remains unchanged as we work to verify the potential root cause and test possible fixes. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 16:00 UTC
Update
Update: Our engineering team has identified a potential root cause of the email service disruption and is currently verifying it while testing possible fixes. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 15:30 UTC
Update
Update: Our engineering team continues their efforts to resolve the email service issues. The current situation remains the same. Current Impact: Email delivery delays persist, and some users are still experiencing difficulty viewing emails after logging in. Data Security: No emails or data will be lost during this incident. All messages are securely stored and queued for delivery once service is fully restored. Our next update will be provided within 30 minutes. We understand this prolonged disruption is frustrating and thank you for your ongoing patience.
Posted Oct 07, 2025 - 15:01 UTC
Update
Update: Our engineering team remains focused on resolving the email service disruption. The current status is unchanged. Current Impact: Some users are still unable to view emails after logging in, with ongoing email delivery delays. Important: No emails or data will be lost. All messages remain securely queued and will be processed once normal service resumes. We are committed to resolving this issue and will provide our next update within 30 minutes. Thank you for your patience as we work to restore full functionality.
Posted Oct 07, 2025 - 14:31 UTC
Update
Update: Our engineering team is actively working to resolve the ongoing email service issues. There has been no change to the current situation. Current Impact: Some users remain unable to view emails after logging in, and email delivery delays continue. All emails are still safely queued and will be delivered once service is restored. We will continue to monitor the situation closely and provide our next update within 30 minutes. We sincerely apologize for the extended inconvenience and appreciate your continued patience.
Posted Oct 07, 2025 - 13:59 UTC
Update
Update: Our engineering team continues to work on resolving the email service issues. The situation remains unchanged from our previous update. Current Impact: Some users are unable to view emails after logging in, and email delivery continues to be delayed. All emails remain safely queued and will be delivered once the technical issues are resolved. We will provide our next update within 1 hour. We apologize for the continued inconvenience and thank you for your patience as we work to restore full service.
Posted Oct 07, 2025 - 12:58 UTC
Update
We are currently experiencing delays with email delivery. Some users may also be unable to view emails after logging in. Impact: Unable to view emails after logging in - service affected for some users Rest assured that no emails will be lost - all messages are safely queued and will be delivered once our engineering team resolves the ongoing technical issues. We will provide our next update within 30 minutes. We apologize for any inconvenience and appreciate your patience.
Posted Oct 07, 2025 - 12:25 UTC
Update
Our engineering team continues to investigate the service disruption. We will provide further updates as soon as additional information becomes available.
Posted Oct 07, 2025 - 11:51 UTC
Investigating
Some email users are experiencing issues accessing their emails. Our team is working to resolve this as quickly as possible.
Impact: Unable to view emails after logging in Service affected for some users
All emails are safe and will be accessible once the issue is resolved.
Posted Oct 07, 2025 - 10:56 UTC
This incident affected: Hostinger Email (Hostinger Mail).