Hostinger client panel maintenance
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Nov 23, 2019 - 20:44 UTC
Investigating
We are performing Hostinger client panel maintenance.
Customer websites are not affected and will be functionating properly.
Apologies for any inconveniences. Thank you for your patience.
Posted Nov 23, 2019 - 20:11 UTC