.APP, .DEV Domain registration and management issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 14:50 UTC

Investigating

We are currently experiencing temporary infrastructure issues that might directly impact our users who are trying to register or manage .app and .dev. domains. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Dec 10, 2025 - 13:13 UTC
This incident affected: Core Services (Domain Registration & Management System).