A fix has been implemented and we are monitoring the results.
Posted May 13, 2025 - 15:53 UTC
Update
You may experience errors while performing various actions in the Control Panel ( hPanel ) related to email section or accessing Webmail itself. Please note, that no emails will be lost during delivery and regular mail functionality will be restored in a timely manner. Thank You for Your patience.
Posted May 13, 2025 - 14:11 UTC
Investigating
We have noticed some connection timeouts in our main Websites infrastructure, for that reason You may experience issues while trying to reach main Hostinger pages. Our team is currently working on resolution and please note that client websites are not affected. Thank You for Your patience.
Posted May 13, 2025 - 14:05 UTC
This incident affected: Email Hosting services (Hostinger Webmail).