Hostinger mail issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 12:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2024 - 12:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2024 - 11:50 UTC
Investigating
We apologize for any inconvenience caused. Our monitoring systems have detected some issues that may cause performance degradation or partial downtime. However, we assure you that your websites will not be affected.

Thank you for your understanding and patience.
Posted Apr 01, 2024 - 11:23 UTC
This incident affected: Email Hosting services (Hostinger Mail).