Hostinger websites maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Dec 24, 2019 - 09:19 UTC
Investigating
We are currently performing maintenance on main Hostinger websites. Visitors might experience interruptions loading our main websites.
Posted Dec 24, 2019 - 09:09 UTC
This incident affected: Core Services (Hostinger Website).