We have resolved the issue, and access to the server has been fully restored. We will continue to monitor the server to ensure stability.
Posted Aug 20, 2025 - 04:15 UTC
Update
Our datacenter engineers are actively working to restore access to the server as quickly as possible. We will provide further updates as soon as they are available.
Posted Aug 20, 2025 - 02:27 UTC
Identified
We have identified the issue, which is related to a hardware component of the server. Our engineers are currently working to restore access as quickly as possible.
Posted Aug 20, 2025 - 01:34 UTC
Investigating
We are performing an emergency maintenance on server us-bos-pve-node352, located in the US. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.