Email Service Degraded Performance

Incident Report for Hostinger

Update

We are still actively investigating the issue and will provide an update once we have new information
Posted Aug 14, 2026 - 17:28 UTC

Investigating

We’re investigating an issue causing delays in email delivery. Some users may also be unable to view emails after logging in.
All messages are safely queued and will be delivered once the issue is resolved.
We apologize for the inconvenience and appreciate your patience.
Posted Aug 14, 2026 - 16:28 UTC
This incident affects: Hostinger Email (Hostinger Mail).