A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2026 - 19:08 UTC
Investigating
We are continuing to investigate publish issue related to latency increase for website publishes.
Posted Mar 07, 2026 - 18:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2026 - 17:52 UTC
Update
We are continuing to investigate this issue. related with Hostinger Horizons websites hosted on my-kul datacenter. Publish and live website may experience issues with integrated backend enabled.
Posted Mar 07, 2026 - 17:14 UTC
Investigating
We’re investigating a service disruption affecting users on the Hostinger Horizons platform. Our team is working to identify the cause of publish failures and restore normal operations as quickly as possible. We apologize for the inconvenience caused.
Posted Mar 07, 2026 - 15:46 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor).